baijunyao / laravel-support
Laravel Support
v2.0.0
2026-10-29 12:28 UTC
Requires
- illuminate/support: ^5.5|^6.0|^7.0|^8.0|^9.0|^10.0|^11.0|^12.0|^13.0
Requires (Dev)
- friendsofphp/php-cs-fixer: ^3.5
- larastan/larastan: ^3.0
- orchestra/testbench: ^9.1|^10.0|^11.0
- phpstan/phpstan: ^2.0
- phpunit/phpunit: ^11.5
Suggests
None
Provides
None
Conflicts
None
Replaces
None
README
Compatibility
Laravel 13 requires PHP 8.3 or later. CI covers Laravel 13 on PHP 8.3–8.5, and Laravel 11 and 12 on PHP 8.3. Existing Illuminate dependency constraints for older releases are retained.
Development
With PHP 8.3 or later:
composer update --with orchestra/testbench:^11.0 composer phpunit composer phpstan composer phpcs -- --dry-run --diff
Features
Str::isTrue()Str::isFalse()Str::isNull()Str::isJsonArray()Str::isJsonObject()
Installation
composer require baijunyao/laravel-support